PDA

Visualizza versione completa : [Gothic, Gothic 2, LNDC] D3D11-Renderer



mathuin
20-06-2015, 21.23.01
http://i.imgur.com/tXWwOM1.png

Nazionalità degli sviluppatori: http://forum.worldofplayers.ru/media/sonstiges/flags/DE.gif
Giochi coinvolti: Gothic, Gothic 2: La Notte del Corvo
Tipologia di aggiornamento: Patch
Nome operativo: D3D11-Renderer per Gothic
Versione: X17.1
Lingue: http://forum.worldofplayers.ru/media/sonstiges/flags/GB.gif
Grandezza: ~10 MB

Autori/sviluppatori: Degenerated (http://forum.worldofplayers.de/forum/members/162334-Degenerated)
Pagina del forum: D3D11-Renderer für Gothic 2 (alpha) #18 (http://forum.worldofplayers.de/forum/threads/1456102-D3D11-Renderer-f%C3%BCr-Gothic-2-%28alpha%29-18)

Stato: Alpha
Data di pubblicazione: 04.09.2014
Data aggiornamento: 15.07.2015


INTRODUZIONE

Questa modifica mira a modernizzare il motore di gioco di Gothic 1&2. Tramite una implementazione personale della DirectDraw-API e tramite hooking e modifiche dell'assembler delle chiamate interne del motore di Gothic, sono riuscito a sostituire completamente la vecchia architettura di rendering con una nuova, la quale è in grado di sfruttare la potenza di calcolo delle GPU di nuova generazione per il rendering.
L'eseguibile originale di Gothic cercava di eliminare il più possibile gli oggetti da rappresentare e questo richiedeva molto lavoro alla CPU, facendo rallentare il gioco anche su processori moderni. Mentre il renderer originale svolgeva un ottimo lavoro con la tecnologia del 2002, oggi le GPU sono diventate molto più veloci e non risentono del carico di lavoro aggiunto.

E ora che possono sfruttare tutta la loro potenza per il rendering, otterremo non solo un miglioramento delle prestazioni sulla maggior parte dei sistemi ma anche nuove caratteristiche, come potete leggere sotto.

Ombre dinamiche
Raggio visuale aumentato
Prestazioni migliorate
HBAO+
Riflessi dell'acqua
Atmospheric Scattering (diffusione della luce data dall'atmosfera)
Heightfog (nebbia che cambia densità con l'altezza)
Normal mapping
Illuminazione dinamica
Generazione della vegetazione
Tassellatura hardware
Editor per inserire alcune caratteristiche del nuovo renderer nel mondo di gioco
Framework per UI basato su Direct2D
Aggiornamento automatico, per essere sicuri di star utilizzando sempre l'ultima versione.


IMMAGINI E VIDEO

Galleria by Jurigag (http://forum.worldofplayers.de/forum/members/112836-Jurigag) (L'Hiver + D3D11) -> https://imageshack.us/a/VDHz/1

Ctuhg8ym-Hk BdTcofHsINQ


DOWNLOAD E INSTALLAZIONE

Scegliete innanzi tutto che versione volete utilizzare per l'installazione del renderer...

Installer -> Version X17.1 (http://www.gothic-dx11.de/download/XVersions/GD3D11-X17_1.exe)
ZIP -> Version X17.1 (http://www.gothic-dx11.de/download/XVersions/GD3D11_X17_1.zip)

Essendo l'installer in tedesco, io vi consiglio di scaricare il file ZIP. Scompattate il contenuto dello ZIP nella cartella system ed è fatta. Se invece volete usare l'installer, assicuratevi che punti alla cartella in cui avete installato Gothic 2. Di solito quella di default è C:\Programmi\JoWooD\Gothic II per i sistemi a 32 bit, C:\Programmi (x86)\JoWooD\Gothic II per quelli a 64 bit. Il renderer cercherà nuovi aggiornamenti ad ogni avvio del gioco, se presenti, li installerà in automatico.

Normal mapping

Il normal mapping è una tecnica usata per migliorare il rilievo delle superfici, l'aspetto degli oggetti, dei modelli ecc., su Wikipedia potete approfondire se volete.
https://it.wikipedia.org/wiki/Normal_mapping

Quando avvierete il gioco per la prima volta col renderer installato, vedrete in alto a sinistra una barra di avanzamento...

http://thumbnails116.imagebam.com/47779/7f00d6477788361.jpg (http://www.imagebam.com/image/7f00d6477788361)

... praticamente è il renderer che sta scaricando il pacchetto con tutta la roba modificata in normal mapping per il gioco originale. Aspettate che finisca e poi iniziate a giocare. Questa cosa verrà fatta solo al primo avvio, quindi non vi preoccupate, le volte successive potrete giocare direttamente.

Se decidete di usare una patch grafica (quella di vurt o L'Hiver Edition ad esempio), però, ovviamente i modelli e gli oggetti cambieranno rispetto al gioco originale, quindi il renderer avrà bisogno del pacchetto in normal mapping anche per la patch grafica.

Se dovessero esserci problemi col download automatico del pacchetto, dovrete scaricarlo e installarlo voi manualmente.

Gioco originale -> http://www.gothic-dx11.de/download/Normalmaps_Original.zip
Vurt's Gothic II Graphics Overhaul -> http://www.gothic-dx11.de/download/replacements_vurt.zip
L'Hiver Edition -> http://www.gothic-dx11.de/download/Normalmaps_LHiver.zip

I file .dds vanno copiati in system\GD3D11\textures\replacements\Normalmaps_Ori ginal, sovrascrivendo quando vi viene chiesto.


FAQ

Posso disattivare il renderer temporaneamente senza dover disinstallarlo?
Sì, vi basterà rinominare il file ddraw.dll nella cartella system di Gothic.

Posso usare questo renderer con i miei salvataggi correnti?
Sì!

Il renderer modifica qualcosa nei miei salvataggi?
No, non modifica nulla del mondo di Gothic, lo legge solamente.

Windows mi dice che mi manca MSVCP110.dll, cosa dovrei fare?
Installate il VC Redist Package (2015) (https://www.dropbox.com/s/mqulhyavrguq20i/vc_redist.x86.exe).

C'è qualche impostazione particolare?
Premendo il tasto F11, si aprirà un menu dove trovate moltissime impostazioni. Tenete premuto Ctrl + F11 per far apparire un altro menu con impostazioni più avanzate. Solo eventuali modifiche fatte nel primo menu verranno salvate!

Uso Windows 10 e una scheda video AMD. Il gioco crasha o si blocca durante il caricamento.
Premete il tasto F11 per richiamare il menu con le varie impostazioni e disattivate l'SMAA.

Quando apro il menu delle impostazioni appare una finestra che dice che devo scaricare un aggiornamento per Windows. Di che si tratta?
Windows 7 non supporta DXGI 1.2, che serve per disegnare il menu con l'accelerazione hardware usando le Direct2D. Quell'aggiornamento corregge il problema.

Mi dà errore 0xc0000005 all'avvio!
Significa che una applicazione 32-bit sta tentando di eseguire codice a 64-bit. Cancellate MSVCP110.dll dalla cartella system del gioco.

Il gioco crasha o ci sono altri problemi!
Inviatemi il "Gothic II\system\Log.txt" con una descrizione dettagliata di cosa è successo. Potete postarlo sul forum o inviarmelo per e-mail, è indifferente.

Puoi implementare questa X o Y caratteristica?
Sarò ben felice di valutare i vostri pareri/proposte. Potete scrivere nel Bug-Pad (link più sotto) o in questo topic.

Ho sentito che il renderer è disponibile anche per Gothic 1. Come lo installo?
Purtroppo la versione per Gothic 1 ha ancora bug e problemi. Se volete provarla, scaricate la preview build da GitHub (link sotto) e scompattate tutto nella cartella system di Gothic. È necessario avere il Player-Kit installato.

Bug-Pad: https://titanpad.com/uoe54x6JaZ
Non dovete essere registrati per scrivere su questo documento, tutti possono contribuire a segnalare i bug riscontrati, però cercate di non spammare. Anche idee e proposte vanno qui, ma saranno discusse meglio nel forum.

GitHub-Repository: https://github.com/Degenerated1123/GD3D11
Nella cartella "PreviewBuilds" troverete versioni in fase di sviluppo. Se volete avere l'ultimissimo aggiornamento potreste voler dargli un'occhiata. Tenete presente, però, che si tratta di versioni non ultimate.

Sakkio
21-06-2015, 01.05.35
Grazie ragazzi... ho condiviso il tutto sia nel gruppo su Facebook che sulla pagina di Google+ :approved:

marco 999
21-06-2015, 08.50.05
Ottimo lavoro davvero non vedo l'ora di provarlo!Ma allora basta istallare l'eseguibile sulla cartella di Gothic 2 presente su C e farlo partire con il Gothic Starter come quando lo si fa partire con la patch di Frank?Tutto qui?

mathuin
21-06-2015, 09.55.45
Esatto, marco. Partirebbe anche avviando il gioco vanilla, senza nient'altro installato (patch e MOD vari), praticamente si va a sostituire al vecchio renderer.

Mi raccomando con le normal map, se hai intenzione di usare le texture di vurt o L'Hiver, leggi bene le FAQ.


Grazie ragazzi... ho condiviso il tutto sia nel gruppo su Facebook che sulla pagina di Google+ :approved:
Non sapevo ci fosse un gruppo su FB, ho appena inviato la richiesta di adesione, chi mi accetta?=D

marco 999
21-06-2015, 10.23.06
Cosa vulo dire "con le normal map"?E che intendi con texture del vurt?il gioco non è gia modificato col le nuove textures?

mathuin
21-06-2015, 11.47.57
Allora, il renderer solo già migliora la grafica, ma sposta anche il carico di lavoro dalla CPU alla VGA, ottimizzando di conseguenza le prestazioni. Se leggi lo speciale (http://www.gothicitalia.it/modding.aspx/articolo/speciale-gothic2-dx11) capisci meglio.

Il normal mapping è una tecnica usata per migliorare l'aspetto degli oggetti, modelli ecc., all'avvio del gioco il renderer scaricherà il pacchetto con tutta la roba modificata in normal mapping (per il gioco originale). Se decidi di usare una patch grafica, però, ovviamente i modelli e gli oggetti cambiano rispetto al gioco originale, quindi il renderer avrà bisogno del pacchetto in normal mapping anche per i nuovi oggetti. Per questo, oltre al gioco originale, il renderer supporta anche due texture patch (quella di vurt e L'Hiver Edition), essendo in fase di testing solo queste due per ora, probabilmente più in là l'autore aggiungerà la compatibilità anche con altre patch grafiche.

Ho cercato di renderlo il più semplice possibile, non so, spero avrai capito.

marco 999
21-06-2015, 12.29.04
Aaahhh ok ok..capito tutto!!grazie mille :asd:

mathuin
21-06-2015, 12.38.23
Se hai intenzione di provarlo (il renderer), mi raccomando, segnala eventuali bug che riscontri nel bug-pad (https://titanpad.com/uoe54x6JaZ). O anche nel thread su WoG, se non te la cavi con l'inglese, posta qua ché traduco e giro io il tutto all'autore.

marco 999
21-06-2015, 12.40.16
Ok..comunque posso istallare solo il render giusto?si può giocare tranquillamente lo stesso?

mathuin
21-06-2015, 12.53.13
Sì, te l'ho detto, installi il renderer e ti scarica automaticamente le normal map per il gioco originale. Fai finire il download e inizi a giocare.

marco 999
21-06-2015, 12.56.05
Ok perfetto,ti ringrazio.

NeapolitanTricker
22-06-2015, 15.00.13
Non so se l'aggiunta di questa mod,ReShade SweetFx,Cambi qualcosa ma direi che è uno spettacolo per gli occhi!!

https://www.youtube.com/watch?v=2VlYS9HVWv8

marco 999
22-06-2015, 18.28.57
Sì, te l'ho detto, installi il renderer e ti scarica automaticamente le normal map per il gioco originale. Fai finire il download e inizi a giocare.

Forse faccio una domanda stupida..ma funziona con l'xp a 32 bit o devo istallarlo su Windows 7?

mathuin
22-06-2015, 18.36.10
Credo proprio di sì, prova, al limite, se hai qualche problema, posti qua e vediamo insieme.

marco 999
22-06-2015, 19.03.24
Credo proprio di sì, prova, al limite, se hai qualche problema, posti qua e vediamo insieme.

Cioè ho istallato tutto..faccio per far partire il gioco ed esce la schermata:che mi manca MSVCP110.dll..ho windows xp..ho scaricato il programma dal link che hai postato il dropbox..ma non è un programma per salvare i dati?
L'ho istallato e aggiornato ma l'errore si presenta sempre..che può essere?

gugand
22-06-2015, 19.05.19
Non mi pare che le DX11 siano ufficialmente supportate da windows XP che e' fermo alle 9.0c.
Le DX11 dovrebbero girare solo da W7 in poi.

Ho verificato, e' cosi'. Esistono modi per installare le DX superiori alle 9 su XP, ma e' un parto perche' non e' una cosa che Microsoft supporta. Se fai ricerche qualcosa trovi, tipo questo: http://www.hwupgrade.it/forum/showthread.php?t=1962889

E' per le DX10, ma ti da una idea di quanto bisogni lavorarci sopra.

marco 999
22-06-2015, 19.13.41
E infatti!!per quello ho chiesto se andava bene sull'xp che è fermo al 9.0c di directx..bon bon allora lascio stare dai..mi gioco gothic 2 normale con le patch sul sito di gothic italia..grazie mille
Però se volessi istallare gothic 2 su Windows 7 cosa devo fare? Cioè c'è qualche cosa da istallare oltre il gioco?

gugand
22-06-2015, 19.16.52
Niente di particolare. Installi il gioco normalmente. Io l'ho provato su windows 8.1 senza problemi quando ho fatto un test del modi di Frank95

marco 999
22-06-2015, 19.22.47
Ah...ottimo dai lo provo sul mio mostro ah ah ah!!!!grazie!

mathuin
22-06-2015, 19.58.38
I passaggi corretti da effettuare sono: installazione Gothic 2 -> installazione espansione La Notte del Corvo -> installazione SystemPatch -> patch di Frank-95 -> renderer. Puoi anche installare prima il renderer e poi la patch di Frank, è indifferente. Così facendo, hai un G2 aggiornatissimo sia graficamente che come stabilità (bug fixati ecc.), io direi che almeno queste cose sono necessarie, soprattutto quando ci sarà una versione definitiva del renderer. A quel punto diventerà obbligatorio secondo me, perché davvero migliora tanto. Una volta installato SP, patch di Frank e renderer, puoi aggiungere quello che vuoi, patch grafiche o MOD, ovviamente controllando se possono creare incompatibilità.

Questo per G2, per G1 non saprei, ma credo proprio che per G1 valga solo la pena aspettare il GRM.

Per quanto riguarda il tuo problema, vedo che ti ha risposto già gugand. Butta Windows XP nel gabinetto!:D

marco 999
22-06-2015, 20.11.08
E lo so, uso un pc vecchio x i primi due gothic...ah ah ah quando trovo un po di tempo li istallo tutti su quello nuovo. :)

mathuin
22-06-2015, 20.23.33
In questi giorni dovrebbe essere rilasciata la versione X17 del renderer, la quale, oltre a fixare alcuni bug segnalati finora dagli utenti, "introdurrà" anche la pioggia. Nessuno si era accorto che non pioveva nel gioco?:asd:

marco 999
23-06-2015, 12.02.04
Si effettivamente è vero..proverò questa mod a fine luglio sono in ferie e ho tempo per mettermi li tranquillo..adesso vado avanti sempre con Gothic 3:metal:
Comunque bravi!Bel lavoro e complimenti per il lavoro svolto..

mathuin
26-06-2015, 12.17.13
È uscita la versione X17.

http://i.imgur.com/dbnhcPz.png

Vi basta avviare il gioco e verrà rilevata automaticamente. Verrà prima disinstallata la versione precedente (X16) e poi installata questa, l'installer è in tedesco ma dovete solo andare avanti, durante la disinstallazione vi comparirà questo messaggio...

http://i.imgur.com/RgCVhif.png

... vi sta chiedendo se volete tenere o no le normal map scaricate finora, premete Sì altrimenti dovrete riscaricarle di nuovo.

auleia
12-07-2015, 18.12.34
È uscita la versione X17.

http://i.imgur.com/dbnhcPz.png

Vi basta avviare il gioco e verrà rilevata automaticamente. Verrà prima disinstallata la versione precedente (X16) e poi installata questa, l'installer è in tedesco ma dovete solo andare avanti, durante la disinstallazione vi comparirà questo messaggio...

http://i.imgur.com/RgCVhif.png

... vi sta chiedendo se volete tenere o no le normal map scaricate finora, premete Sì altrimenti dovrete riscaricarle di nuovo.
Non sapevo di queste novità, vorrei iniziare di nuovo gothic 2, ho la versione
Gold edition di steam, cosa dovrei fare? Per la traduzione cosa devo installare, non ricordo più. Grazie

Colmar
12-07-2015, 20.52.52
Non sapevo di queste novità, vorrei iniziare di nuovo gothic 2, ho la versione
Gold edition di steam, cosa dovrei fare? Per la traduzione cosa devo installare, non ricordo più. Grazie

Non ho la versione Steam di Gothic 2, ma so che comprende anche i sottotitoli italiani, penso che devi andare col tasto destro nelle Proprietà del gioco e selezionare la lingua italiana tra quelle a disposizione.

auleia
12-07-2015, 20.54.36
Ok, non lo ricordo più, perché l'ho disinstallato. Ma la varie novità grafiche sono compatibili con la versione steam, e soprattutto con l'Italiano? Grazie ancora

Inviato dal mio Nexus 5 utilizzando Tapatalk

mathuin
12-07-2015, 23.18.43
Vai tranquillo, il renderer è compatibile con Steam e non influisce in alcun modo sulla lingua di gioco. Se poi, oltre al renderer, vuoi installare anche il texture patch de L'Hiver, è un altro discorso.

L'unica cosa che ti raccomando è quando installi il SystemPack, che è necessario per installare questo renderer... qui c'è il thread del SP (http://forum.multiplayer.it/showthread.php?671331-Gothic-%BD-SystemPack), leggi bene le istruzioni per l'installazione.

auleia
13-07-2015, 08.24.22
Quindi, se qualcuno può farmi un riepilogo con i link, di quello che devo installare, sarei grato. Grazie ancora.

Inviato dal mio Nexus 5 utilizzando Tapatalk

mathuin
13-07-2015, 09.56.09
Devi installare prima il SystemPack...

1. Installare "Gothic 2: Gold Edition"
2. Installare Gothic2_fix-2.6.0.0-rev2.exe (http://dl1.worldofplayers.ru/games/gothic/patches/G2/gothic2_fix-2.6.0.0-rev2.exe)
3. Installare Gothic2_PlayerKit-2.6f.exe (http://www.bendlins.de/nico/gothic2/gothic2_playerkit-2.6f.exe)
4. Installare G2NoTR-SystemPack-1.1.exe (http://dl1.worldofplayers.ru/games/gothic/patches/systempack/g2notr-systempack-1.1.exe)

... poi ti leggi questo bel thread, c'è proprio la parte Download e subito sotto Installazione. E vedi come si installa il renderer.

auleia
13-07-2015, 13.21.31
Grazie, per la traduzione ci saranno problemi? Dove devo installare i file, li devo estrarre in una directory, in quale? Grazie.

Inviato dal mio Nexus 5 utilizzando Tapatalk

mathuin
13-07-2015, 23.34.48
Ti ripeto che il renderer non influisce sulla lingua, è una "cosa" che ti permettere di migliorare la grafica, quindi non ha nessun effetto sui file della lingua.

auleia, secondo me ti piace fare il furbetto... i post non ti piace leggerli, eh? Leggi il primo post, c'è scritto tutto ed è spiegato alla perfezione.

auleia
14-07-2015, 08.17.21
Perché dovrei fare il furbo ? Se non capisco è colpa mia, quindi chiedo, se non si vuole rispondere, non si è obbligati a farlo, grazie.
EDIT, mi sono accorto che ci sono due cartelle system, ho spostato e adesso funziona, grazie.
nviato dal mio Nexus 5 utilizzando Tapatalk

marco 999
28-07-2015, 13.44.59
Ciao allora sono riuscito a istallare Gothic2 con la directx11..tutto bene a parte che i video iniziali si vedono molto piccoli in proporzione allo schermo...L'Hyver mod come si istalla?Ho visto che sono file dds li ho copiati nella stessa cartella di quelli della directx11 ma il mondo di gioco non è cambiato..che devo fare?Grazie!!

marco 999
29-07-2015, 21.56.05
Risolto tutto..stupendo davvero stupendo ma mi sembra che con L'Hyver mod la patch di Frank non funzioni..e come mai non si può più dormire sui letti ???

mathuin
07-08-2015, 18.21.18
Ero in vacanza, sei riuscito a risolvere alla fine?

auleia
07-08-2015, 18.35.53
Ero in vacanza, sei riuscito a risolvere alla fine?
anche io ho risolto tutto, ho installato anche l'hiver mod, ci sono incompatibilità con il renderer? unica cosa che non riesco ad impostare nel menu dell'hiver, in audio, l'effetto in "grotte ecc" non ricordo il nome. grazie ancora.

marco 999
07-08-2015, 18.39.34
Si tutto risolto..però l'eseguibile..il file che va copiato sulla cartella data l'ho preso da un altro sito,le normal map scaricate e funziona però quando oremo f11 non si apre il menu..mi dice che bisogna fare un aggiornamento per w7..il link però a cui l'avviso si riferisce non esiste..

marco 999
07-08-2015, 18.41.17
Poi non so..non si vedono più le barre della stamina ne quelle della mana con L'Hyver mod però ho visto che ci sono gli alligatori..non capisco se la patch di Frank funziona

mathuin
07-08-2015, 21.08.08
Allora, marco, voglio aiutarti, ma devi spiegarti meglio e soprattutto cercare di scrivere meglio in italiano. Davvero non ho capito nulla.

marco 999
07-08-2015, 21.31.27
Faccio fatica a scrivere perché non ho sempre il pc sottomano il più delle volte uso il cell e faccio molta fatica a scrivere bene..:asd:...beh...non c'è molto da dire...il file che è l'eseguibile del Hyver edition il vdf, l'ho scaricato da un altro sito perché copiando i file normal map dell'Hyver nella cartella apposta il gioco non partiva...cmq..va e tutto bene..quando premo il tasto f11 esce un menu che mi dice di fare un aggiornamento Windows...il link a cui si riferisce x scaricarlo non c'è più...boh..quindi come faccio a aprire il menu x le impostazioni avanzate?grazie..se si può fare bene seno amen il gioco va benissimo cosi..solo ecco non riuscivo a farlo partire solo con le normal map dell'Hyver presenti qua sul forum ecco..

mathuin
08-08-2015, 14.11.34
Nelle FAQ è presente questa domanda.


Quando apro il menu delle impostazioni appare una finestra che dice che devo scaricare un aggiornamento per Windows. Di che si tratta?
Windows 7 non supporta DXGI 1.2, che serve per disegnare il menu con l'accelerazione hardware usando le Direct2D. Quell'aggiornamento corregge il problema.

Hai scaricato quell'aggiornamento?

Il gioco, se vuoi farlo partire con le normal map de L'Hiver, devi installare anche L'Hiver. Mi sembra abbastanza ovvia come cosa.

marco 999
08-08-2015, 14.14.57
....si lo so anche io questo non sono nato ieri. IL link dell'aggiornamento non esiste..carica la pagina a vuoto o il download non è più disponibile. .e dove lo trovo L'Hyver da istallare?io ho trovato solo le normal map sul forum il file vdf l'ho scaricato da rpgzone e istallato sulla cartella principale del gioco, allora il gioco è partito.

mathuin
08-08-2015, 18.00.08
Qui non c'è perché sto ancora preparando il thread per L'Hiver, appena lo finisco lo posto qui. Su RPG Zone va benissimo, solo che lì è stato fatto un launcher che comprende tutto il materiale necessario per installare L'Hiver.

Installi prima il vdf de L'Hiver, poi metti la patch di traduzione (sempre vdf) e poi scarichi le normal map. Le normal map hai letto come vanno installate, sì?

marco 999
08-08-2015, 18.05.22
Si si il gioco funziona benissimo Matteo è tutto ok..:) solo...vorrei provare il Virtu mod...ma cone si fa?Ho provato a istallare le normal map sulla solita cartella ma non succede nulla..

mathuin
08-08-2015, 18.34.03
Intendi la patch di vurt? Credo non sia possibile giocare a quella e L'Hiver contemporaneamente... per provarla devi levare L'Hiver (togliendo il vdf dalla cartella Data) e cancellare le normal map de L'Hiver. Dopodiché installi prima la patch di vurt e poi scarichi le normal map apposite per essa.

marco 999
08-08-2015, 19.09.25
Ah infatti lo immaginavo..sai dove posso trovare la patch?L'Hyver è stupendo ma veramente molto diverso dal caro vecchio Gothic.

mathuin
08-08-2015, 20.33.59
La patch di vurt la trovi qui (http://forum.worldofplayers.de/forum/threads/1145749-G2-MOD-Vurt-s-Gothic-II-Graphics-Overhaul), sostituisci anche l'ini (https://www.dropbox.com/s/up8k52rwozdvnsp/Gothic.ini), mi raccomando.

Io ti consiglio di fare così, per fare le cose un po' più "pulite":

1) Cancella innanzi tutto l'intera cartella Normalmaps_Original che trovi in system\GD3D11\textures\replacements
2) Così facendo, quando avvii il gioco, esso scaricherà nuovamente le normal map per il gioco originale
3) Una volta scaricate, esci dal gioco e installa la patch di vurt e l'ini che ti ho linkato prima
4) Scarica le normal map per la patch di vurt qui (http://www.gothic-dx11.de/download/replacements_vurt.zip) (apri lo ZIP scaricato e copia i singoli file .dds, non la cartella, in Normalmaps_Original, sovrascrivendo quando ti viene chiesto

marco 999
08-08-2015, 20.53.13
Oookk perfetto domani provo mille grazie :D non ho ancora ben capito se con l?hiver la patch di frank funziona..voglio dire..le barre di mana e stamina che sono visibili in basso sullo schermo con l'stallazione dell'Hiver scompaiono..ho visto che gli alligatori ci sono ancora nel mondo di gioco perciò..dovrebbe esserci..in ogni caso voglio provare il Vurt..oggi penso di provarla e poi scrivo che ne penso;)

mathuin
09-08-2015, 12.24.51
L'ho notato anche io, però credo per le altre cose funzioni la patch di Frank. Lui attualmente sta lavorando per integrare quella di vurt, non so che ha intenzione di fare con L'Hiver. Altrimenti te lo giochi senza patch di Frank.:D

marco 999
09-08-2015, 13.01.25
Si mi sembrava che avesse accennato alla sua nuova patch integrata con il Vurt..deve correggere diverse imperfezioni della sua patch e se riesce a inserire il Nostalgic Mod..ok allora casomai gioco con la dx11,provo il Vurt e quando Frank rilascia la patch rigioco Gothic2..speriamo esca qualche bel mod per il primo Gothic..L'ho provato con il sistem pack su Windows 7 64bit..è molto scorrevole veramente piacevole...comunque x il file ini lo devo sostituire se voglio provare il Vurt giusto?Posso tenere la mod di colmar con le textures modificate o da incompatibilità con le textures del Hiver o del Vurt?

marco 999
09-08-2015, 17.05.50
Provato il Vurt...decisamente molto più vicino al vecchio Gothic,ci sono le barre stamina e mana,si può dormire sui letti tranquillamente, ho risolto il problema legato alla riduzione dello schermo quando partivano i filmati cambiando il file ini,tutto ok, molto bello davvero.

auleia
11-10-2015, 12.19.38
ho qualche problema con l'hiver, ci sono oggetti "volanti", oggetti tipo piante che si trovano in abitazioni, pareti mancanti. cosa posso fare? grazie.

Frank-95
14-10-2015, 20.41.36
We, scusate l'assenza, comunque no la l'hiver non è disponibile con la mia patch, in quanto modifica gli script, quindi o usi uno o l'altra. Però, se esiste, sarebbe compatibile con eventuale versione senza mondi e script.

EDIT


Si mi sembrava che avesse accennato alla sua nuova patch integrata con il Vurt..deve correggere diverse imperfezioni della sua patch e se riesce a inserire il Nostalgic Mod..ok allora casomai gioco con la dx11,provo il Vurt e quando Frank rilascia la patch rigioco Gothic2..speriamo esca qualche bel mod per il primo Gothic..L'ho provato con il sistem pack su Windows 7 64bit..è molto scorrevole veramente piacevole...comunque x il file ini lo devo sostituire se voglio provare il Vurt giusto?Posso tenere la mod di colmar con le textures modificate o da incompatibilità con le textures del Hiver o del Vurt?

Wow che bel minestrone che vuoi fare :P

Allora la regola è: una sola mod per gli script, quindi decidi te se nostalgic, la mia o la l'hiver. E quante te ne pare di quelle grafiche, sapendo che se più d'una modificano la stessa texture, verrà usata quela più recente. La l'hiver è putroppo sia grafica che di script, e non ti so dire se esiste una versione solo grafica. Inoltre essendo la più recente sostituirà praticamente tutte le texture di vurt e di colmar. Quindi decide te cosa usare :P

auleia
14-10-2015, 20.55.34
Ho disinstallato, e adesso ho la vurt's. Scusate, cosa sono gli script? In cosa consiste la Frank? Grazie

Inviato dal mio Nexus 5 utilizzando Tapatalk

marco 999
17-10-2015, 11.27.35
We, scusate l'assenza, comunque no la l'hiver non è disponibile con la mia patch, in quanto modifica gli script, quindi o usi uno o l'altra. Però, se esiste, sarebbe compatibile con eventuale versione senza mondi e script.

EDIT



Wow che bel minestrone che vuoi fare :P

Allora la regola è: una sola mod per gli script, quindi decidi te se nostalgic, la mia o la l'hiver. E quante te ne pare di quelle grafiche, sapendo che se più d'una modificano la stessa texture, verrà usata quela più recente. La l'hiver è putroppo sia grafica che di script, e non ti so dire se esiste una versione solo grafica. Inoltre essendo la più recente sostituirà praticamente tutte le texture di vurt e di colmar. Quindi decide te cosa usare :P

Allora..ho provato un po di cose..attualmente penso che la miglior configurazione(ovviamente a mio parere personale),sia: DX11,la tua patch ovviamnte e la mod Vurtu..ho provato a istallare anche le texture modificate di Colmar,il risultato è un mix tra quelle del Vurt e quello appunto di Colmar.
L'effetto è molto particolare,l'erba è sfumata cosi come le texture degli edifici,alberi,cespugli, e il resto del mondo.;)

auleia
17-10-2015, 12.42.20
Nella patch di Frank, dice di installare in una cartella Io non la vedo, la devo creare? Grazie.
Le directx 11 mi hanno creato problemi insieme a l'hiver mode.

Inviato dal mio Nexus 5 utilizzando Tapatalk

marco 999
17-10-2015, 13.01.11
Ora non mi ricordo che cartella..mmm si dovrebbero sostituire dei file se non ricordo male.
La cartella c'è di sicuro guarda meglio,x i problemi alla dx11 scrivi quali messaggi di errore escono.

auleia
17-10-2015, 13.15.20
ok, installata.

Inviato dal mio Nexus 5 utilizzando Tapatalk

mathuin
18-10-2015, 20.50.44
Una versione senza mondi e script c'è, l'ha fatta Marcello. Però non l'ho ancora provata.

Che problemi ti dava L'Hiver con le DX11? Prova a disattivare le voci Tesselation e SMAA, non ho avuto più un crash da quando le tengo disattivate.

auleia
18-10-2015, 21.17.46
Una versione senza mondi e script c'è, l'ha fatta Marcello. Però non l'ho ancora provata.

Che problemi ti dava L'Hiver con le DX11? Prova a disattivare le voci Tesselation e SMAA, non ho avuto più un crash da quando le tengo disattivate.
Ho disinstallato, ho solo la vurt's. Grazie lo stesso. Con L'Hiver sparivano oggetti, ecc...

mathuin
18-10-2015, 21.58.29
Ovvio, perché L'Hiver non è solo una patch grafica, modifica qualcosa anche a livello di script, andava in "conflitto" con quella di Frank. Vabbè che alla fine te l'ha spiegato anche lui.

Comunque, qui c'è L'Hiver solo come patch grafica -> L'Hiver Edition Grafikpatch für Gothic 2 (http://forum.worldofplayers.de/forum/threads/1391645-L-Hiver-Edition-Grafikpatch-f%C3%BCr-Gothic-2).

auleia
18-10-2015, 22.00.13
Ovvio, perché L'Hiver non è solo una patch grafica, modifica qualcosa anche a livello di script, andava in "conflitto" con quella di Frank. Vabbè che alla fine te l'ha spiegato anche lui.

Comunque, qui c'è L'Hiver solo come patch grafica -> L'Hiver Edition Grafikpatch für Gothic 2 (http://forum.worldofplayers.de/forum/threads/1391645-L-Hiver-Edition-Grafikpatch-f%C3%BCr-Gothic-2).
L'Hiver l'avevo installato senza nessun altra mod...

Inviato dal mio Nexus 5 utilizzando Tapatalk

marco 999
20-08-2016, 17.41.40
Ho provato la DX11 per Gothic 1 l'ho trovata qui: https://steamcommunity.com/sharedfiles/filedetails/?id=484664831
Peccato non sia ancora la versione definitiva, purtroppo si verificano bug con un certa frequenza, le finestre di dialogo a volte spariscono e i video si vedono molto male.
Però intanto ho avuto un assaggio della DX 11 ..che dire..è stato emozionante girare per il mondo di gioco,vedere i riflessi di luce,l'acqua e le ombre migliorate :D
Chissà che esca o almeno il GRM sia finito in tempi brevi.

mathuin
20-08-2016, 18.55.43
Da qualche parte avevo letto che era uscita la X17.3, però se all'avvio il renderer non me la segnala significa che forse è ancora in beta.

marco 999
20-08-2016, 20.08.21
Non ho provato con il collegamento a Internet..dopo faccio una prova..vediamo se scarica qualcosa.

mathuin
20-08-2016, 21.04.03
E secondo te io non avevo Internet collegato?:D

Comunque non la segnala perché non è del tutto ufficiale, però Degenerated la consiglia ugualmente, si può scaricare qui.
https://github.com/degenerated1123/GD3D11/blob/master/PreviewBuilds/GD3D11_PreviewReleaseG2.zip

Ovviamente per installarla bisogna usare il metodo manuale, quindi scaricare lo ZIP e estrarre il contenuto in system.

marco 999
20-08-2016, 23.35.01
Non è affatto male invece..ho giocato x un po e girato un po di posti..qualche bug c'è e qualche sfarfallio di textures ma x il resto mi sembra non ci siano grossi problemi..si hai ragione Matteo non c'è nessun aggiornamento a parte la x17,1.
Parte appena faccio partire G1 con la DX11.

marco 999
17-07-2017, 11.53.51
Ciao raga..piccolo dubbio non mi ricordo più come si fa a riportare i video di G1 e G2 a grandezza naturale dopo aver installato la dx11..bisogna modificare qualcosa dal file ini ma non mi ricordo più..vi ringrazio..

ghiso9026
18-07-2017, 15.47.41
Devi modificare la stringa "scaleVideos" da 0 a 1 nel gothic.ini

marco 999
19-07-2017, 12.02.51
Devi modificare la stringa "scaleVideos" da 0 a 1 nel gothic.ini

no, non cambia nulla è gia 1 come valore impostato..

ghiso9026
19-07-2017, 23.01.12
no, non cambia nulla è gia 1 come valore impostato..

Si hai ragione ho controllato, con le dx11 sia con 1 o 0 i video restano piccoli. Funziona solo senza dx11

marco 999
20-07-2017, 12.29.34
Si hai ragione ho controllato, con le dx11 sia con 1 o 0 i video restano piccoli. Funziona solo senza dx11

Eppure l'anno scorso mi ricordo che ero riuscito ad ingrandire i video cambiando qualcosa dal file ini..o da un altro file boh!! :tsk:

mathuin
21-07-2017, 17.24.06
Provate a cambiare quella voce dal SystemPack.ini, non dal Gothic.ini.

marco 999
22-07-2017, 10.39.03
Provate a cambiare quella voce dal SystemPack.ini, non dal Gothic.ini.

Sul file systempack.ini non c'è alcuna voce "Scale video"...c'è forse qualche altro parametro che si deve modificare?

mathuin
23-07-2017, 13.30.16
Quoto quello che mi hanno detto nel thread ufficiale.


It's a bug with newer versions of the DX11 Renderer.
Go back to version 17.1 and turn scaleVideos in gothic.ini to 0 and it works.

marco 999
23-07-2017, 15.52.36
Ah vedi...grazie x l'interessamento.

mathuin
26-07-2017, 17.37.12
Non so se ha già risolto, ma mi hanno proposto anche un'altra soluzione.


The following solution worked for me very well. Please find FixBink=1 in your SystemPack.ini file and set it to FixBink=0

marco 999
23-10-2017, 23.19.24
Ottimo funziona!!