PDA

Visualizza versione completa : Problema con quest translator 0.9 (4600 quest tradotte)



DaKaGi
20-07-2008, 22.09.32
Ho un grosso e bizzarro problema con questo mod.

Alcuni mesi fa giocavo tranquillamente sui server ufficiali con Wow + espansione Burning Crusade con il mod quest translator 2 funzionante.

In questa settimana sono stato costretto a reinstallare world of warcraft in quanto lo avevo disinstallato temporaneamente per problemi al pc.
Rifaccio tutta l'installazione (espansione compresa) e tutte le patch fino all'ultima patch disponibile attualmente. (la 2.4.3 mi pare).

Reinstallo la mod quest translator 2 e avvio il gioco. La mod appare correttamente caricata quando clicco nella finestra Addons prima di entrare in game ma Ŕ come se non ci fosse.

In game non mi appare l'icona del libricino in alto a dirmi quante quest sono tradotte e le quest sono tutte in inglese.
Praticamente mi appare "QT2 enabled" o qualcosa del genere sulla barra sotto ma a parte quello nient'altro che dia segno di vita.

Come mai ??

Potrebbe essere dovuto a un problema di file di sistema ? qualche pasticcio ?

Sto diventando matto e non riesco a capire perchŔ non funziona quando dovrebbe funzionare.

DaKaGi
20-07-2008, 23.42.20
Adesso faccio il culo a qualcuno. :@ :asd:

Ho fatto una prova.
Ho provato a disinstallare la mod quest translator 2 e ho installato la mod precedente 1.7 (con 3275 quest tradotte) e funziona perfettamente.

Praticamente il problema non Ŕ dovuto a server ufficiali (e di problemi simili al mio ne ho letti tanti in questo forum) o non ufficiali ma ad un incompatibilitÓ del quest translator 2 con le nuove patch rilasciate della Blizzard. Evidentemente Ŕ causa di un conflitto o di un problema che impedisce all'addons di funzionare come dovrebbe.

Avevo giÓ il sospetto che il problema fosse dovuto a una cosa del genere. Ne ho avuta la conferma.

JackFrost
22-07-2008, 11.00.46
Ciao Dakagi! Se guardi il thred pinnato, negli ultimi post ho presentato un problema identico al tuo. Carico tutto, addons rilevati, avvio il gioco, mi dice qt2 enabled, ma niente. Prover˛ anche io a scaricare qualche versione precedente!

DaKaGi
22-07-2008, 13.50.04
Ciao JackFrost

Si infatti.
E puoi stare tranquillo che il problema non dipende dal server che usi per giocare.

Ora che ci penso mi pare che la versione del mod quest translatori 2 v. 0.8 non dovrebbe dare nessun problema, in quanto mi ricordo che giocavo con tale addons e la patch era giÓ arrivata alla 2.4.2.

:)
Peccato che su multiplayer attualmente si trova solamente la v. 0.9 :(

JackFrost
22-07-2008, 15.10.13
Ciao! Ho provato ad installare la 1.7 ed effettivamente funziona! Servirebbe l'intervento divino di qualche mod che avvisi gli sviluppatori di questo "piccolo" bug.

DaKaGi
22-07-2008, 20.30.21
Ho trovato una soluzione per risolvere il problema del mancato funzionamento del mod quest translator 2.

Praticamente Ŕ possibile utilizzare l'ultima traduzione disponibile (attualmente quella che traduce 4600 quest) utilizzando i file della versione precedente dell'addon.

Spiego i procedimenti passo per passo.

1. Scaricare l'ultima versione del mod quest translator 2 qui sito multiplayer (si trova in formato zip) e scompattarla nella cartella interface/addons. Vengono scompattate diverse cartelle (QuestTraslator2, quest_db00, quest_db01, ecc ...)

2. Scaricare una versione precedente del mod quest translator 2 contenente solamente la cartella questTranslator2 ossia il motore di traduzione dal sito Index of /QuestTranslator2/ (http://files.wowace.com/QuestTranslator2/)
Scaricare il file che si chiama QuestTranslator2-r75496.1.zip risalente al 9 giugno 2008.

3. Scompattarlo nella cartella dove Ŕ stato scompattato l'addons sovrascrivendo la cartella QuestTranslator2. (i file di traduzione delle quest non vengono toccate perchŔ non sono presenti, si sovrascrivono solo i file principali, ossia quelli che permettono all'addon di funzionare)

4. Avviare Wow e la traduzione dovrebbe funzionare correttamente.


Facendo in questo modo la traduzione funziona, mi appare il libro in basso e ho 4600 quest tradotte. E comunque se mi causa problemi posso sempre disattivarla.

:roll3: :roll3:

Spero di essere stato di aiuto.

:)

Golemino
22-07-2008, 20.37.55
Sto facendo dei controlli, mi sembra strano che non funzioni la 0.9
Potete darmi l'elenco degli addon che usate, o meglio potete provare a disabilitare tutti gli addon tranne QuestTranslator (la versione 0.9) per vedere se continua a non funzionare?

Provate anche a cancellare dalla cartella WTF\..\SavedVariables tutti i file che fanno riferimento all'addon:
QuestTranslator2.lua
QuestTranslator.lua
QuestCollector.lua

Grazie

DaKaGi
22-07-2008, 22.27.22
Avevo provato a disinstallare WOW e reinstallarlo in modo da cancellare le cache e tutti i file relativi all'addon di traduzione. Ho provato perfino col repair pensando che il problema fosse dovuto a dei file danneggiati o corrotti.
Precedentemente usavo due mod : quest helper e quest translator e funzionavano entrambi.

Quando ho reinstallato wow l'ultima volta ho installato solamente Quest helper per ovviare a problemi di conflitto con l'altro addon, ma senza successo.

Golemino
22-07-2008, 23.33.39
Finalmente sono riuscito a riprodurre l'errore.
Diversamente dal solito non erano altri addon a dargli fastidio, ma al contrario era la presenza di altri addon (ancora non ho capito quale) che bypassava l'errore che invece si verifica quando c'Ŕ solo il QuestTranslator2 attivo.

Ora cerco una soluzione e spero a breve di aggiornare la versione.

JackFrost
23-07-2008, 02.55.33
Anche io senza nessun addons oltre a QT2, reinstallato, fixato e tutta la storia. Grazie per lo sbattimento Golemino.

Col procedimento di DaKaGi funziona tutto alla grande! Thanks mate ;)